Home > Not Working > Amp Has Power But No Sound From Subwoofer

Amp Has Power But No Sound From Subwoofer

Contents

Weather or not it does, your grounding location needs to be addressed regardless. if all these check go good check your input signal. Sub is likely rated for 400RMS, which the amp is rated to produce [email protected] ohms, so it could be that the gain were set too high and that could have damaged Also, nice mess of wiring. Source

mode 3 could potentially do as well, but I don't know off hand which channels it deems as the bridged channels. They went back out two days ago and idk wtf is going on. JDM Killa 956,536 views 10:15 Car Stereo Head Unit Install ** No Sound ** Amp Not Turning On ** work around. ECU not getting power By ProbeGT-ZE in forum Tech Talk Replies: 6 Last Post: 12-15-2009, 10:38 PM cluster is not working??? navigate to this website

Amp Has Power But No Sound From Subwoofer

RE: Car subwoofer not working? Then after testing my subs on his amp with still nothing. Just connect the 9V to the speaker wires that go to the sub after disconnecting them from the amp. We also know that the sub is a DVC 2 ohm model that is presenting a 4 ohm final impedance, so it's coils must be wired in series.

take the subs out of the box check for loose connections. I am completely stuck right now, so any help would be great! The ground is the black wire that comes off the amplifier and gets screwed into the chassis of your car. Car Amp Wont Turn On When I came back, the sub didn't work anymore.

I tried lightly pushing down on the subs cone and it seems to move smooth and does not make any sort of weird noise. if you have a cap remove it and by pass this to make sure your cap isn't ruined, reconnect everything if this doesn't work. 3. The amp isn't lighting up so there's apparently no power going to it.

I checked the fuse on my cable and found it to be intact although there was some black charred marks on the connectors.

high quality amplifier, I would assume that the amp is past its useful life for the cheap price. Amp Not Getting Power GlassWolf Platinum MemberUsername: GlasswolfPost Number: 13665Registered: Dec-03 Posted on Wednesday, May 26, 2010 - 19:27 GMTconnect the ipod to the amp. I've checked that all wires are still connected and they are. The selector was set to 4 I changed it to 2 and didn't change anything.

My Amp Turns On But No Sound From Subs

This is a major cause of overheating. Home Entertainment Centers: Building your Own Home Theater Environment Home Media: TV and Sound, PC and Projection Media Formats and Technologies Home Sound: Setting up and getting the most from your Amp Has Power But No Sound From Subwoofer Disconnect the system from the battery and open the panels to check that there are no loose ends and everything is in place. Subwoofer Not Working Amp Has Power At OneHowTo we give you all the possible options.

Forum Search Like Tweet Home > Forum > Car Audio Forum > Car Subwoofers Forum > Archive through May 31, 2010 Forum > Subwoofer stopped working all the sudden Ridetopdown New http://noipc.org/not-working/iphone-power-button-not-working.html Sometimes you can unscrew the subwoofer from the box, look inside, and check for a bad connection. ghostlyrich 12,989 views 10:01 Car Amplifier Repair - Duration: 20:54. You may also be interested in: Why Does My Car Shake When I Brake Check the Connections on Your Car Subwoofer The first and the simplest thing to do to know Car Subwoofer Troubleshooting

My amp shows that it has power but currently has no output. You have posted to a forum that requires a moderator to approve posts before they are publicly available. 12 About Crutchfield Because my name is on the business, I work hard This time they were out for a couple days. have a peek here When I turned my car on to play music and measure the AC voltage of the amp's speaker outputs (described in last post) I unplugged them from my sub like you

Keep your RCA cables, power and ground connected. Car Subwoofer Not Working I know it was not the best set up but until now did not know about a subsonic filter. Now a clipped signal on the other hand is usually pretty apparent, but if you never knew what it sounds like, it may not be so apparent.

A fuse holder?

I hear distortion, background noise, crackling, and hissing in the speakers First check to see how your wires are ran. To learn more, visit our web site at www.movinon.com.One of the most popular add-ons for a car stereo is a subwoofer/amp combo. I mean you set the DMM for AC voltage and with music playing, were measuring the speaker output terminals of the amplifier looking to any sort of voltage. Car Subwoofer Troubleshooting No Sound Working...

Loading... Crutchfield is a trademark of Crutchfield New Media, LLC. This is to prevent the amp from being overloaded or ‘blown’ and will save you a lot of trouble in the long run. Check This Out You have posted to a forum that requires a moderator to approve posts before they are publicly available.

Ridetopdown New memberUsername: RidetopdownAtlanta, GA United States Post Number: 2Registered: May-10 Posted on Wednesday, May 26, 2010 - 19:53 GMTthe way i had the ipod hooked up was with something like I hear engine whine The biggest cause of engine whine through amplified speakers is the ground. check the power cable at these places, the fuse if you have an anl fuse, the power cap and at the amp its self 2b. I tried it with my other amp that I had in my last car and it would turn on but still nothing through the subwoofers.

The guy at Bestbuy said he re-wired everything and I even checked to make sure and all the wiring is perfectly fine. You can only upload files of type PNG, JPG, or JPEG. So I have concluded that it is either my HU or my amp is just dead. (deffpossibly it is old and not high quality) Any help or tips would be appreciated. It could be that the RCA inputs are bad on the amp, RCA preamp outputs are bad on the stereo, ground may be too weak for the amplifier to power up,

to match with my amp? If it is good, check the blue wire from the deck to the amp (switch) if it is good, hook the test light to the power wire and check the ground.